Welcome Guest, you are in: Login

ScrewTurn Wiki

RSSRSS

Navigation




Search the wiki


PoweredBy

Main menu

RSS
Modified on 2011/11/05 15:16 by Ekaterina Paths: Tutorial Categorized as Panels and menus

Description

At the top left corner a Main Menu is shown (Figure 1). Options in this main menu are defined as: File, Edit, Experiment, Event, Library, Parameters, Snippets and Actions.

Image
Figure 1: Main menu on the Main window.

Menus

File Menu

File menu allows the user to:
  • create New files,
  • Open existing files (from a known folder within a browsable system),
  • Save current experiment with the same previous name and in the same previous location
  • Save As to give the current file a new name and save it in a new location if desired.
  • Change basic Preferences (see the table)
  • Enable and disable AddIns with AddIn Manager, which shows the path to the Addin directory.

Image
Figure 2: What is seen upon clicking on Prefereces

NameDescriptionDefault settings
Display
Runtime DisplayThe system monitor that will display the main experimental window. "Auto Selection", the primary display will be used.
SubScreen DisplayThe system monitor that will display the operator screen. "Auto Selection, the secondary display will be used.
Code editor
Font:The font that will be used when displaying code snippets. Courier New
Font SizeChanges the size of the font used to display code snippets. 12
Background Changes the background colour of the snippet boxes.White
Font ColorChanges the font color of the snippet code.Black
GUI settings
GUI AnimationTurns on and off animation of graphical user interface. True. Working on slow computer select 'False' to get better GUI performance.
Run history
Secured Period (days)Set up maximal age of the run history in days. Any run record and associated report data with a longer age will be removed automatically, if the record is not locked in the history.7

Edit Menu

Similarly to many other programs, the Edit option allows the user to
  • Undo (Ctr+Z) the previous action,
  • Cut (Ctr+X),
  • Copy (Ctr+C)
  • Paste (Ctr+V) snippets of code and elements.

Event Menu

The Experiment option allows users to
  • Add New Event (Ctrl + F8)
  • Delete Event.

Events are a fundamental notion of EventIDE; they could be defined as every little step in the experiment, as every temporal moment in the experimental sequence. New event appears on the Event panel.

Image
Figure 3. New added event

Links between events can also be controlled using
  • Make Circular Links,
  • Make all-to-Links
  • Delete Selected Links option.
    See the Layers section for more information on linking events.

Element Menu

Event is used to add new elements to an event (see Elements and Resource Library). Images, videos and buttons (Figure 4) are considered elements and these can be added or deleted using the Event menu option. These elements will be used to construct the events; an event has no sense without elements defined therein.

Image

Figure 4: Elements available in Event option. These are the possible structures that could be added to an Event to define this particular step in experiment development.

Library Menu

The Library option gives you the possibility of interacting with resources in the experiment such as images and videos (see Elements and the Resource Library). When Library menu is selected (Figure 5) from the main menu you can:

  • Load items: Allows you to add a new file to the library from a particular folder.
  • Add Custom XAML: Allows you to add a new sheet of code where you can define, through XAML code whatever figure (Ellipse, Rectangle, Line, Cross) you are interested in. These kind of elements are interesting because they can adopt properties such as changing size as a function of time or other parameters, or changing colour or position whereas images cannot.
  • Resources in the library will be sorted in alphabetical order, if the option Ascending Order is selected.
  • To Add folder is also possible - not a single image or element but a whole folder of them will be added, converting into accessible resources for EventIDE.
  • Update items is a useful option if images or elements in the experiment have changed slightly. Provided that the files names are the same, this option will update the file within EventIDE, without the need to reimport new files as new elements.
  • Resources can be deleted from the library either using the Delete items option or by selecting those resources in the library that you want to delete and just pressing Delete on the keyboard.

Figure 5: Library options are only available when library is selected in the main screen.

Proxies Menu

Several properties of an element can be converted using the parameters functionality. When one or more of these properties are selected this option allows you to convert them to parameters which form the base of your code. In the snippets you can introduce these parameters and functions to change them as your experiment goes on or to get them in a data file. The options are
  • add Proxy,
  • add proxy array
  • add proxy hub.
  • Remove Proxy
  • Rename proxy
  • You can also unpin all proxies (see Proxy Variables for description).

Snippets Menu

Using the snippets boxes the user can develop code to manipulate the experiment as required. The Snippet option on the Main Menu allows the user to
  • compile Snippets(Ctrl+F9) - to compile the snippets in the experiment
  • compile Snippet (F9) - for compiling a particular code snippet box - F9.
  • close snippet
  • close all open Snippets
  • save current snippet
  • load current snippet

Figure 6: Possible actions from the snippets option on the main menu.

Actions Menu

This menu refers to particular run actions such as
  • run preview(F5) - Run preview is useful in the situation where the experiment designer has added an extra "operator screen" to be seen by the experimenter, but not by the participant. When working on a single monitor, both windows will be visible using the Run Preview option.
  • run experiment(Ctrl+F5)

The user can look at and export statistics and any reported data using options such as
  • save last report,
  • exporting to excel
  • open run history
  • open run log.
    Users have to specify (using code) which data should be made available for export, and will be discussed in more detail in the code section.

Help

This menu is the last but not the least. It contains the link to
  • the online wiki(F1), where you can get information about panels, element, snippets and other program concepts
  • program visit card, where you can see current version number, appearing after click on About button.

ScrewTurn Wiki version 5.2.0.8. Some of the icons created by FamFamFam.